The latest SVN bugs thread

You discovered a bug in the engine, and you are sure that it is not a problem of your code? Just post it in here. Please read the bug posting guidelines first.

Re: The latest SVN bugs thread

Postby CuteAlien » Mon Jan 16, 2012 5:16 pm

Hm - can you try something - set the material BlendOperation to EBO_ADD. That seems to fix all similar problems usually.
IRC: #irrlicht on irc.freenode.net
My Irrlicht code snippets: https://code.google.com/p/irr-playground-micha/
My patches&stuff: http://www.michaelzeilfelder.de/irrlicht.htm
Play a fun racer created with Irrlicht: http://www.irrgheist.com/
User avatar
CuteAlien
Admin
 
Posts: 6407
Joined: Mon Mar 06, 2006 2:25 pm
Location: Tübingen, Germany

Re: The latest SVN bugs thread

Postby MolokoTheMole » Tue Jan 17, 2012 8:34 am

Nope, nothing changes.
Crimson Glory full Irrlicht game source code!
What I Do - my blog & dev log
Currently developing Link-Dead
MolokoTheMole
 
Posts: 104
Joined: Tue Jan 09, 2007 1:18 pm

Re: The latest SVN bugs thread

Postby CuteAlien » Tue Jan 17, 2012 10:22 am

Hm, sorry, then I can't really say much about it. But Hybrid is still working on alpha-stuff, so maybe just a wait a while. Or even better - if you can create some test-code + data to reproduce this for us then it would certainly help a lot!
IRC: #irrlicht on irc.freenode.net
My Irrlicht code snippets: https://code.google.com/p/irr-playground-micha/
My patches&stuff: http://www.michaelzeilfelder.de/irrlicht.htm
Play a fun racer created with Irrlicht: http://www.irrgheist.com/
User avatar
CuteAlien
Admin
 
Posts: 6407
Joined: Mon Mar 06, 2006 2:25 pm
Location: Tübingen, Germany

Re: The latest SVN bugs thread

Postby kaos » Wed Jan 18, 2012 10:18 pm

In windows, like example 14(window mode) with directx 9.0c there are problems with ZBUFFER.
kaos
 
Posts: 155
Joined: Tue Aug 12, 2008 8:25 pm
Location: Spain

Re: The latest SVN bugs thread

Postby RdR » Fri Jan 20, 2012 1:21 pm

I'm trying to save a custom scene node to a irrscene file.
But saving and/or loading the MaterialTypeParam is not properly working

cpp Code: Select all
 
Material.MaterialTypeParam = video::pack_texureBlendFunc(
video::EBF_SRC_ALPHA,
video::EBF_ONE_MINUS_SRC_ALPHA,
video::EMFN_MODULATE_1X,
video::EAS_TEXTURE | video::EAS_VERTEX_COLOR);
 
User avatar
RdR
Competition winner
 
Posts: 269
Joined: Tue Mar 29, 2011 2:58 pm

Re: The latest SVN bugs thread

Postby hybrid » Fri Jan 20, 2012 1:52 pm

This was also reported in another thread. We need to switch to an int parameter where we can safely store these bitfields. Not sure if we can fix this for 1.8, though, as it needs some investigations in material usage in general.
hybrid
Admin
 
Posts: 14143
Joined: Wed Apr 19, 2006 9:20 pm
Location: Oldenburg(Oldb), Germany

Re: The latest SVN bugs thread

Postby RdR » Wed Jan 25, 2012 8:43 pm

I updated to the latest Irrlicht version (trunk) today (rev 4054), using the nightly build.
But the shadows in DirectX 9 are not working anymore, first I thought it was my project, but even the examples (tutorial 8 ), doesnt have any shadows in DirectX.
User avatar
RdR
Competition winner
 
Posts: 269
Joined: Tue Mar 29, 2011 2:58 pm

Stencil Shadows artefacts

Postby ACE247 » Sat Jan 28, 2012 5:45 pm

Latest SVN Build
Compiled on Linux, OpenGL with X11
Sorry for the large size, but its neccessary.
Image
User avatar
ACE247
 
Posts: 704
Joined: Tue Mar 16, 2010 12:31 am
Location: Namibia

Re: The latest SVN bugs thread

Postby kaos » Wed Feb 01, 2012 9:46 am

kaos wrote:In windows, like example 14(window mode) with directx 9.0c there are problems with ZBUFFER.



Nvidia GeForce GTX 560 Ti have problems with ZBUFFER( I'm making one application with viewports in windows with directx sdk and visual express 2010), My program work great in Nvidia GeForce GT 550M (from my notebook)
kaos
 
Posts: 155
Joined: Tue Aug 12, 2008 8:25 pm
Location: Spain

Re: The latest SVN bugs thread

Postby kaos » Thu Feb 02, 2012 4:48 pm

kaos wrote:
kaos wrote:In windows, like example 14(window mode) with directx 9.0c there are problems with ZBUFFER.



Nvidia GeForce GTX 560 Ti have problems with ZBUFFER( I'm making one application with viewports in windows with directx sdk and visual express 2010), My program work great in Nvidia GeForce GT 550M (from my notebook)


I found the problem, If I make my rtt more little than my resolution. Not work

if I have 1680x1050 I need set render target size to 1681x1051.
kaos
 
Posts: 155
Joined: Tue Aug 12, 2008 8:25 pm
Location: Spain

Re: The latest SVN bugs thread

Postby greenya » Sat Feb 25, 2012 3:10 pm

Checking 4094 rev.
Also some problem with OpenGL rendering.
Please check the difference:
http://filebeam.com/c97168854f39e202e3c ... 4b3298.jpg
Image
If i switch to "bump mapping" mode, then i see only "mipmap defect"; if i switch to "diffuse" mode, then no defects.
Direct3D8/9 rendering has no defects in any mode.
User avatar
greenya
 
Posts: 1003
Joined: Sun Jan 21, 2007 1:46 pm
Location: Ukraine

Re: The latest SVN bugs thread

Postby hybrid » Sun Feb 26, 2012 2:08 pm

The problem in the example seems to be a merge error. I guess I had the driver choice changed in trunk already, and now merged the same change again.
The problems with bump mapping were not recognized before. I have to check if they are here as well.
hybrid
Admin
 
Posts: 14143
Joined: Wed Apr 19, 2006 9:20 pm
Location: Oldenburg(Oldb), Germany

Re: The latest SVN bugs thread

Postby greenya » Mon Feb 27, 2012 12:33 pm

The problem with bump mapping i checked with 2 video cards:
- GeForce GTX 460M (with OpenGL 4.2.0) // reproducible (screenshots in previous post)
- Radeon X1650 (with OpenGL 2.1.8545) // NOT reproducible
User avatar
greenya
 
Posts: 1003
Joined: Sun Jan 21, 2007 1:46 pm
Location: Ukraine

Re: The latest SVN bugs thread

Postby Mel » Mon Feb 27, 2012 2:57 pm

I checked it too.

GeForce 6500 with OpenGL 1.2 only (this card doesn't have more) with the same results.
http://santiagong.daportfolio.com/
"There is nothing truly useless, it always serves as a bad example". Arthur A. Schmitt
User avatar
Mel
Competition winner
 
Posts: 1812
Joined: Wed May 07, 2008 11:40 am
Location: Granada, Spain

Re: The latest SVN bugs thread

Postby greenya » Sat Mar 03, 2012 2:43 pm

Hello!

This is not a bug of current SVN trunk version, but other thing.
I had found that something that was added quite long time ago in SVN trunk never gets to release version.
For now I found only one thing (don't know how much there are more):

ITimer.h in 1.7.3 release has no EWeekday enum, RealTimeDate struct and getRealTimeAndDate() method, which was added to SVN trunk at 7th september 2010 (in rev. 3395).
So i was thinking that maybe its some bug in managing trunk and branches?

P.S.: i'm just reporting (want you to know).
User avatar
greenya
 
Posts: 1003
Joined: Sun Jan 21, 2007 1:46 pm
Location: Ukraine

PreviousNext

Return to Bug reports

Who is online

Users browsing this forum: No registered users and 0 guests