Irrlicht 1.8.4 release

A new bugfix release for the Irrlicht 1.8 series. This one is mostly about getting it to compile with gcc5 and c++11.
Visit the forum thread for more info about changes.
Download the zip here.

Enjoy!